x

Apple’dan Eski iOS Cihazları İçin Uyumlu Uygulama Fırsatı

Apple’dan Eski iOS Cihazları İçin Uyumlu Uygulama Fırsatı

Apple, yeni mobil işletim sistemi iOS 7‘nin final sürümünü yarın herkesin kullanımına açacak. iOS 7, iPhone 4 ve üstü modeller ile iPad 2 ve üstü, iPad mini ve beşinci nesil iPod Touch’ı desteklerken eski model cihaz sahipleri güncellemeden yararlanamayacakları için endişe duyuyorlar. Ancak son ortaya çıkan bir durum, bu kullanıcıları da sevindirecek gibi gözüküyor. Zira Reddit‘te bir kullanıcının tespit ettiği üzere eski model iOS cihaz kullanıcıları uygulamaların eski versiyonlarını cihazlarına indirebilecek.

iOS 7 ile birlikte uygulama geliştiriciler harıl harıl uygulamalarını bu sürüme göre modifiye edip güncellerken iOS 7’yi desteklemeyen iPhone 3GS gibi cihaz sahiplerinin bu uygulamalardan faydalanamayacağı düşünülüyordu. Ancak Apple, kullanıcıların uygulamaların eski versiyonlarını indirmesine izin vermeye karar vermiş gibi gözüküyor.

Ortaya çıkan bu yeni durumla iOS 5 yüklü bir iPhone sahibi, ilk kez indirdiği bir uygulamanın son sürümü iOS 7’ye uyumlu olsa da o uygulamanın iOS 5 ile çalışan versiyonunu cihazına indirebilecek. Böylelikle cihazlarını son iOS sürümüne yükseltmemeyi tercih eden kullanıcılar da uygulamalardan mahrum kalmamış olacaklar.

iOS 5.0

Bir uygulamayı indirmeye çalıştığınız anda Apple uyarı servisi size uygulamanın en son sürümünün hangi işletim sistemini gerektirdiğini hatırlatırken daha eski versiyonunu yüklemek isteyip istemediğinizi soruyor. Eğer uygulamanın eski versiyonunu cihazına yüklemek istiyorsanız indir tuşuna dokunmanız yeterli oluyor.

Bu durum eski iOS cihaz sahipleri kadar uygulama geliştiricilerin de işine gelecek gibi. Böylece geliştiriciler arşivledikleri eski sürümlerini hiçbir şey yapmadan kullanıcıların hizmetine sunmuş olacaklar. Ancak API üzerinden bağlantı kuran uygulamaların eski versiyonlarında sorun yaşaması da muhtemel gibi duruyor.

Yorumlar (0)

Bir Cevap Yazın